• deaf_fish
    link
    fedilink
    11 year ago

    Okay, even if I give you the unexpected behavior point. The readability problem remains. Switch statements or tables will work just fine and are easier to read.

    To be clear, I am fine with single ternary operations. I think nested ternary operations are harder to read and follow.

    • @Serdan@lemm.ee
      link
      fedilink
      11 year ago

      I agree you should use a switch where applicable, but ternaries are the expression equivalent of if-else statements. If I have two conditions and a default, and each branch simply evaluates to a value of the same type, I’ll probably just use a ternary.