• schnurrito@discuss.tchncs.de
    link
    fedilink
    arrow-up
    28
    ·
    9 months ago

    “result” is fine. That is the variable you will end up returning that you have to fill with stuff first.

    “data” on the other hand…

    • Hal_Canary@lemmy.sdf.org
      link
      fedilink
      English
      arrow-up
      4
      ·
      9 months ago

      I came here to say this.

      Declare result in the first line of the function and return result is the last line. In C++, this is a big hint to the compiler that you want return value optimization to kick in.

  • erogenouswarzone@lemmy.ml
    link
    fedilink
    English
    arrow-up
    22
    ·
    9 months ago

    As a person who victimizes coworkers like this, I apologize. Thank you for pointing it out, and I will stop doing it.

    • wizardbeard@lemmy.dbzer0.com
      link
      fedilink
      English
      arrow-up
      10
      ·
      9 months ago

      Be proud that it’s a step up from var x

      Be scared that your coworkers are planning how to best apply the baseball bat to your knees anyway

      • Quik
        link
        fedilink
        arrow-up
        1
        ·
        8 months ago

        Will name every of my functions like this now, thank you for pointing out that incredible meaningful name

  • henfredemars
    link
    fedilink
    English
    arrow-up
    15
    ·
    9 months ago

    I’ve had instances where I worked with an API so badly designed in a dynamic language that I had no idea what I might receive.

    This, when I get something back that’s not what I expected, I just logged the type because I really don’t know what it is. It’s the result. Whatever that means.

  • gramie@lemmy.ca
    link
    fedilink
    arrow-up
    14
    ·
    9 months ago

    It could be that this is a habit left over from pascal, where result is a reserved word, and is automatically made the return value of the function.

    If it is in the context of a short function, I don’t see that it’s all that bad.

    • aksdb@feddit.de
      link
      fedilink
      arrow-up
      4
      ·
      9 months ago

      Yup, I also do that. If I just need a variable to put in what will be returned, I call it result. What it means should be clear from the function name. Repeating that feels redundant.

    • Pxtl@lemmy.ca
      link
      fedilink
      English
      arrow-up
      7
      ·
      9 months ago

      Exactly. If it’s a statically typed language and the function has a clear name? I know what type it is, I know what it’s for, I’m good.

      There are far worse sins, like intermediate variables or worse, public class members named “obj” or “data”.

      • qaz@lemmy.worldOP
        link
        fedilink
        arrow-up
        1
        ·
        8 months ago

        GitHub doesn’t show types. So if the value is given to another function you would have no way of knowing what type it is unless you read the file that other function is declared in.

  • owzim@lemmy.world
    link
    fedilink
    arrow-up
    3
    ·
    8 months ago

    As someone who uses ‘result’ as a variable name in functions all the time, please tell me what you think is wrong with it?

    If a function is called for example ‘transformAtoB’ it should be totally obvious what the variable will contain.

    • qaz@lemmy.worldOP
      link
      fedilink
      arrow-up
      1
      ·
      edit-2
      8 months ago

      It’s not necessarily bad, it just provides very little information.

  • pHr34kY@lemmy.world
    cake
    link
    fedilink
    arrow-up
    3
    arrow-down
    1
    ·
    edit-2
    9 months ago

    You declare it as the first line after “function getNextDay() : date {”, then it is glaringly obvious that is a date variable that will (eventually) contain tomorrow’s date, and will be returned by the function.

    However, I would only use “var” if it’s initialized in the same statement. It prevents Smurf code, and the compiler knows the type straight away.

    Given a small and clean context, variable names don’t need to be specific.

  • JoYo@lemmy.ml
    link
    fedilink
    English
    arrow-up
    1
    arrow-down
    1
    ·
    9 months ago

    yah because we’d rather die than use return type hints.